[RC5-PROXYPER] Problem under RH5.0 Alpha

Michael Larocque mrl at riscan.com
Wed Dec 31 21:08:47 EST 1997


On Thu, 1 Jan 1998, Francois E Jaccard wrote:

> Hi,
> 
> I am having a problem that may not be related to the pproxy:
> I had Red Hat 4.2 and I was running the pproxy version 2.6403-261 for linux
> alpha without any problem.
> I now upgraded to RH 5.0 and I have now "Error locating host
> rc5europroxy.distributed.net"
> I can ping any address, xxx.xxx.xxx.xxx or www.foo.bat.com and everything
> works except the proxy!
> I have 6 PC that use this proxy and they can return the completed blocks
> without problem.
> 
> Any idea?

Yup, I ran into this same problem - I'm pretty sure that it's the new
shared libraries. If you run strace on the perproxy, you'll see that
it is trying to open the 'old' libraries (ie. 4.2 ships with 1.xx
libc, while 5.0 ships with 2.xx glibc) for the network related code. I
haven't tried this, but I _think_ that if you copy over the required
libraries from a 4.2 system, re-run ldconfig, you can get it to work.
Either that, or convince whoever is responsible for the alpha-linux
proxy to re-build it on a 5.0 system. 

I didn't bother, as I was just doing a quick 'test' install on this
system just to get an impression of 5.0 - I don't have anything
'broke' on this system, so I didn't want to 'fix' it :-)

> 
> Thanks and Happy New Year!
> 

Good luck,
Mike


<*> Michael Larocque : mrl at riscan.com <*>
- -----BEGIN PGP PUBLIC KEY BLOCK-----
Version: 2.6.2

mQCNAzLc/0oAAAEEAJ6qHzuY7KUAE19EksW+EaH0gR1Z53BjeFx1z/fWoMmHlrUS
NavWTvXQbP5bnFzdjXU6hy28aRtv9umBDw8RSimZvrvF4g68rM331+w6X0ZKxMWB
JIZnfcowxxtdEe883bQYLFyNV0reQQbHHvLLGi6QwuAROqy4WZjKIrVKuYC5AAUR
tCRNaWNoYWVsIFIuIExhcm9jcXVlIDxtcmxAcmlzY2FuLmNvbT4=
=CCsD
- -----END PGP PUBLIC KEY BLOCK-----

--
To unsubcribe, send 'unsubscribe rc5-proxyper' to majordomo at llamas.net


More information about the proxyper mailing list