[RC5-PROXYPER] Problem with Linux pproxy 275 talking to win32 pproxy 274b?

Mitchell Patenaude mrp at sonic.net
Fri Jan 16 11:21:12 EST 1998


I am also having problem getting my personal proxy to flush blocks..
Here's the setup.. at home I have a IP masqueraded LAN with several
linux boxen hiding behind a ppp-dialup.  One of the linux boxen has
rc5desproxyper-275-linux-x86 on it.  It's set to flush to the
personal proxy sitting on my desktop machine at work (P133 ruuning
NT4 workstation with rc5desproxyper-274b-win32-x86)

Here's what happens typically:
[01/16/98 16:08:15 GMT] Configuration file (rc5desproxyper.ini) reloaded!
[01/16/98 16:08:15 GMT] *Flush*  Initiating manual flush/fetch.
[01/16/98 16:08:15 GMT] Server 1 added to slot 1 ip 209.0.14.85 port 2064
[01/16/98 16:08:17 GMT] The proxy says: [pp] Buddha's proxy service
[01/16/98 16:08:17 GMT] Transmitting completed block to server
[repeated 3 times]
[01/16/98 16:08:17 GMT] Transmitting desII block to server
[repeated 10 times]
[01/16/98 16:08:17 GMT] Requesting desII block from server
[repeated 4 times]
[01/16/98 16:08:20 GMT] Server acknowledged data transmittal
[01/16/98 16:08:20 GMT] Server acknowledged data transmittal
[01/16/98 16:08:20 GMT] Transmitting desII block to server
[01/16/98 16:08:20 GMT] Transmitting desII block to server
[01/16/98 16:08:20 GMT] Server acknowledged data transmittal
[repeated 2 times]
[01/16/98 16:08:20 GMT] Transmitting desII block to server
[repeated 2 times]
[01/16/98 16:08:21 GMT] Server acknowledged data transmittal
[repeated 2 times]
[01/16/98 16:08:21 GMT] rc564 r=75/10, d=0/10, des r=328/500, d=166/500
[01/16/98 16:08:21 GMT] 0d 0:00:30, 0.0 rc5 Mkeys/sec 0.0 des Mkeys/sec
[01/16/98 16:08:21 GMT] Status: Slot 0 LISTENING
[01/16/98 16:08:21 GMT] Status: Slot 1 idle   1 ip 209.0.14.85 SERVER
[01/16/98 16:08:21 GMT] Flushing out-buff to disk.
[01/16/98 16:08:21 GMT] Flushing DES out-buff to disk.
[01/16/98 16:08:21 GMT] Transmitting desII block to server
[01/16/98 16:08:21 GMT] Server closed the connection
[ **** ]
[01/16/98 16:08:21 GMT] Putting back 13 unsent server acknowledgements
[01/16/98 16:08:51 GMT] rc564 r=75/10, d=0/10, des r=328/500, d=178/500

You'll notice right above the **** that the server closed the connection
right after a transmission, so this would appear to be a server timeout
value being set to low, or not resetting the timeout counter when it gets
data (It's a leap, but not too far).

Could this be caused by the older (274b) build on the NT machine?
I'll try upgrading when I get to work, and let you know the
results

The connectivity is good for a dialup.. here's a ping 
--- 209.0.14.85 ping statistics ---
27 packets transmitted, 26 packets received, 3% packet loss
round-trip min/avg/max = 170.2/181.6/214.0 ms

   -- Mitch
-- 
   -- Mitch Patenaude             Software Engineer
      mitch at likeminds.com         LikeMinds Inc.
      mrp at sonic.net (personal)    The MovieCritic
                                  http://www.moviecritic.com/
--
To unsubcribe, send 'unsubscribe rc5-proxyper' to majordomo at llamas.net



More information about the proxyper mailing list