[PROXYPER] Running -repair on v304 pproxy taking hours

Jeff Lawson bovine at distributed.net
Wed Jun 2 05:16:45 EDT 1999


With pproxies before 305, it was possible that a -repair could discover an
infinite loop in the linked list of blocks within the buffer file.  This
would cause a repair to never terminate, and in fact never accomplish
anything.  If you would like me to submit blocks contained within the
buffer, just attach the out buffer to an email to me.  Upgrading to a
newer proxy should eliminate the problem.

-- 
Jeff Lawson   http://www.cs.hmc.edu/~jlawson/   http://www.bovine.net/
Jeffrey_Lawson at hmc.edu   jlawson at bovine.net    bovine at distributed.net
Programmer, Developer, Mascot, Founder of the largest computer on earth!
Don't waste those cycles!  Put them to use!  http://www.distributed.net/

On Tue, 1 Jun 1999, Richard Crow wrote:

> Hello all,
> 
> I came back to work this morning to find that my proxy had not send
> anything out all weekend.  I stopped proxyper and restarted with the
> '-repair' option.  It has been running for almost 3 hours now.  I am
> getting no indication that anything is happening other than my CPU is
> pegged at 100% on that machine.  Here is the log file:
> 
> [root at rce-unix1 proxy]# ./proxyper -repair
> [06/01/99 15:07:31 UTC] Initializing distributed.net Personal Proxy
> (build 304)
> [06/01/99 15:07:31 UTC] Visit http://www.distributed.net/FAQ/ for
> details.
> [06/01/99 15:07:31 UTC] Error, block count does not make sense:
> totalused=0 totalempty=20268 totalunits=20267
> [06/01/99 15:07:31 UTC] Activating contest repair mode.
> [06/01/99 15:07:31 UTC] Beginning recovery process on rc564 inbuff.
> [06/01/99 15:07:31 UTC] initial total used: 26 (cached 26)
> [06/01/99 15:07:31 UTC] initial total free: 516 (cached 516)
> [06/01/99 15:07:31 UTC] final total used: 26 (cached 26)
> [06/01/99 15:07:31 UTC] final total free: 516 (cached 516)
> [06/01/99 15:07:31 UTC] Recovery on rc564 inbuff complete (result
> code=0).
> [06/01/99 15:07:31 UTC] Beginning recovery process on rc564 outbuff.
> [06/01/99 15:07:31 UTC] Error, block count does not make sense:
> totalused=0 totalempty=20268 totalunits=20267
> [06/01/99 15:07:31 UTC] initial total used: 0 (cached 0)
> [06/01/99 15:07:31 UTC] Error, block count does not make sense:
> totalused=0 totalempty=20268 totalunits=20267
> 
> 
> My questions:
> 
> 1.  How do I know that this is working?
> 2.  How long should I expect this to take (Running on Linux kernel 2.2.5
> on a 450 PII with 64mb ram)
> 
> 
> Ideas anyone?
> 
> thanks,
> 
> Richard Crow
> richard at rcrow.com
> 
> --
> To unsubscribe, send 'unsubscribe proxyper' to majordomo at lists.distributed.net
> 

--
To unsubscribe, send 'unsubscribe proxyper' to majordomo at lists.distributed.net



More information about the proxyper mailing list