[PROXYPER] bug in OS/2 perproxy build 374?

waldo kitty wkitty42 at windstream.net
Tue Feb 17 15:27:33 EST 2009


Roman Trunov wrote:
> waldo kitty wrote:
> 
>> i can easily understand that... i guess the confusing part was that 
>> the missing section was not created as other sections have been done 
>> in past versions... i mean, i've never had to create any sections in 
>> all the years that i've been running a perproxy... i've edited the 
>> ones that were created but i've never had to create them...
> 
> it's just impossible. ether you've forgot something, either you've used 
> proxyper.ini from distribution archive (it contains all necessary 
> sections).

that's quite possible... i update the perproxy so very rarely that it is quite 
easy to forget some things ;)

>> actually, i did intentionally remove all sections that were listed as 
>> contestclosed=1 to clean up the ini file of all the old unnecessary 
>> sections before loading the new 347 build of the perproxy...
> 
> i agree that references to old ogr projects can be removed. this is 
> minor issue, but still confusing. but since perproxy is usually changing 
> only before new projects, don't expect this do be done fast :)

well, i'm not complaining about it... i just happened to decide to clean it up 
and then install the new version... since i start the new version in a minimized 
window from a startup script, it was a bit disconcerting that i wasn't able to 
find it running and no log entries as to why it died... as i wrote before, it 
wasn't until i manually ran proxyper.exe that i saw the notation about the 
missing section...

>> i don't understand your last statement "not created missed .ini 
>> sections automatically and refused to start"??
> 
> perproxy will not create missing .ini section. if section is missing, 
> perproxy will not start. perproxy worked this way for at least 6 years 
> (see timestamp of readme.os2 :)

currently i've only got 4 old versions saved... 313, 333, 343, and now 347... i 
don't recall what versions i ran before putting 313 in place and i did have a 
drive crash back in Nov of '99 that really hit hard and i didn't get around to 
reloading the system until the night of 2000 coming in...

  2-13-00  23:12     169498           3687  proxyper313.exe
12-30-02  13:47     170828            273  proxyper333.exe
10-26-08  10:31     162250              0  proxyper343.exe
  2-16-09  19:34     163414              0  proxyper.exe

the first two i extracted from the archive on the os/2 box and i think the other 
two i transferred over via ftp after the lan manager networking stuff got broken 
which i've never been able to fix... so that's why they do not carry any 
extended attributed ;)

so i guess this is not a bug and now that i know what the cause was and that it 
is not a bug, i guess we can call this "case closed" :)

i welcome further comments, though, if you or anyone else want to post them ;)

BTW: i also wanted to thank you for your work maintaining the os/2 version all 
these years... it still works quite well on my Warp3 Connect server 8)

-- 
NOTE: NEW EMAIL ADDRESS!!

        _\/
       (@@)                      Waldo Kitty, Waldo's Place USA
__ooO_( )_Ooo_____________________ telnet://bbs.wpusa.dynip.com
_|_____|_____|_____|_____|_____|_____ http://www.wpusa.dynip.com
____|_____|_____|_____|_____|_____|____ ftp://ftp.wpusa.dynip.com
_|_Eat_SPAM_to_email_me!_YUM!__|_____ wkitty42 -at- windstream.net


---
avast! Antivirus: Outbound message clean.
Virus Database (VPS): 090216-1, 02/16/2009
Tested on: 2/17/09 15:27:34
avast! - copyright (c) 1988-2009 ALWIL Software.
http://www.avast.com





More information about the proxyper mailing list