[rc5] v2 clients not reporting saved work?

Howard Cheng hcheng at cs.ualberta.ca
Fri Jun 27 19:10:53 EDT 1997


hcheng wrote:

>   I have noticed that in both the linux P5 and the Win 32 client, if
> I interrupt the client in the middle of a block and resume it later on,
> the first block that the resumed client finished does not get reported
> back to the server (or at least it doesn't say so in the log).  Here
> is what it says on the Win 95 client.  The linux client is similar:

This is getting more weird.  After waiting for a bit, it basically did
this (summary of what my log says, the majority is in my previous
post):

- working on some block
- interrupt, save work
- resume client, worked on previously saved block.
- go get 5 more blocks, without saying that the result on the last one
  is reported.  It says "retrieved 5 blocks".
- after 4 blocks are done, it says "sent 5 blocks", and fetch another
  5 blocks.

I haven't waited long enough (another 2 hours) to see what it does with
these 5 new blocks.

When it says "retrieved 5 blocks" the first time, does it take into account
of the block already done, and so only retrieved 4 blocks?  This is getting
confusing, because what the log says doesn't seem to be consistent with
what actually happened.

Again, it happened on both the Linux and Win 32 clients.

Howard


-- 
Howard Cheng                     e-mail: hcheng at cs.ualberta.ca
University of Alberta                    hcheng at gpu.srv.ualberta.ca
MSc Computing Science            URL   : http://www.cs.ualberta.ca/~hcheng/

A proof tells us where to concentrate our doubts.
                                          - Morris Kline
----
To unsubscribe, send email to majordomo at llamas.net with 'unsubscribe rc5' in the body.



More information about the rc5 mailing list