[rc5] 2 Linux PProxy questions

James P Blanding blanding+ at andrew.cmu.edu
Wed Nov 5 09:39:45 EST 1997


Excerpts from mail: 5-Nov-97 Re: [rc5] Linux PProxy ques.. by Michael
Zieger at kem.ac.at 
> >The Linux proxy seems to work fine but with one annoyance: when I run the
> >proxy, if it is time to dump or get blocks it usually does that fine.  But
> >after that point, it can never find the damn server again.  My workaround
> >has been to set up a script that actually kills and restarts the proxy
> >every 15 minutes just so it can do the necessary transactions.  Any hints? 
> >BTW, it specifically says "Error finding host rc5proxy.distributed.net"
>  
> Maybe try to get a newer PProxy. I don't see such problems here. The error
> message could be caused by problems with DNS lookup. Try to ping
> rc5proxy.distributed.net, maybe your machine can't resolve the name.


Excerpts from mail: 5-Nov-97 [rc5] Linux PProxy Block Flush by Joseph
Fisk at rm405n-a.rob 
>Hi,
> 
>I am running a personal proxy and was wondering if the folloing output is
>a sign of a problem or not.  No blocks are lost.
> 
>Thanks for any advice.


interesting.  i have noticed a couple of somewhat strange things with
both tbe Linux client and PProxy.  first, i had trouble with the client
from the beginning.  with the default rc5proxy.distributed.net, it would
always get network errors on trying to connect.  when i was watching
with tcpdump, there werent even any packets going out from the client. 
however, i was able to ping/nslookup the server.  i figured maybe it was
a bug with the client and seeing as my machine is up all the time but im
not always connected i figured id try a proxy.
when i started the proxy with the default of rc5proxy.distributed.net it
would go and connect to a server but only d/l 1 or 2 blocks before the
server closed the connection.  sometimes it just wouldnt work period. 
so all i did was start playing with the different possible ip addresses
for the main proxy until i found one that worked for me (of course, i
dont remember now which one it was and im not in linux either :P).  so,
i guess my suggestion is to try putting ips in the ini file instead of
the hostname.  i really dont know *why* any of this would happen--i have
had no problems with the win95 client through the same dial up.  oh
well...hope this helps... 
----
To unsubscribe, send email to majordomo at llamas.net with 'unsubscribe rc5' in the body.



More information about the rc5 mailing list