[RC5] alpha ev56 and ev4 not compatible

Dan Sugalski dan at sidhe.org
Wed Feb 12 12:58:46 EST 2003


At 12:38 AM +1000 2/7/03, Kris Amy wrote:
>Hey all,
>
>I have compiled a test version of the client on an Alpha ev56 cpu. When
>I go to run it on an ev4 it doesn't even start. eg.
>
>kris at alpha:~/dnetc480-linux-alpha5-static$ ./dnetc -test

This isn't too surprising. The EV5 systems have instructions that the 
EV4s don't have and, while you can load up PAL code to emulate 
(slowly) the instructions, it wouldn't surprise me if the linux 
version you're running doesn't do that.

It's also of some benefit to building architecture-specific client 
executables, which is what I ended up doing for the VMS build years 
ago--the EV5 version was faster than the EV4 version on the EV5, but 
the EV5 version was slower than the EV4 version on the EV4, so it 
made sense to do two separate builds.
-- 
                                         Dan

--------------------------------------"it's like this"-------------------
Dan Sugalski                          even samurai
dan at sidhe.org                         have teddy bears and even
                                       teddy bears get drunk
--
To unsubscribe, send 'unsubscribe rc5' to majordomo at lists.distributed.net
rc5-digest subscribers replace rc5 with rc5-digest



More information about the rc5 mailing list